SSLCertificateChainFile obsolète

La directive de configuration d’apache SSLCertificateChainFile est maintenant dépréciée (à partir d’apache 2.4.8) pour spécifier un certificat intermédiaire. Le message d’avertissement nous demande de la remplacer par la directive SSLCertificateFile. Le problème est que cette directive est déjà renseignée avec notre certificat. La solution est triviale:

concaténer les deux fichiers

cat ssl.crt sub.class1.server.ca.pem > bundle.pem

faire pointer la directive SSLCertificateFile sur celui-ci.

SSLCertificateFile bundle.pem

Leave a Reply

Your email address will not be published.

six + 4 =